[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23426: 25.0.93; dired-do-find-regexp doesn't find newline

From: Kaushal Modi
Subject: bug#23426: 25.0.93; dired-do-find-regexp doesn't find newline
Date: Wed, 04 May 2016 16:20:25 +0000

Hi all,

Even understanding that users would need to install GNU find & grep on their Windows system to use the new implementations bound to A/Q in dired, I believe that we should have the following:

- NOT bind A/Q at all if the right dependencies are not found. I tried the A binding on Windows, it looked like it was grepping for the strings I entered and returned an empty *xref* window. The same search on same files worked as expected in RHEL (to be honest I love this new feature on RHEL, and I might start using the A binding). Currently the implementation on Windows gives an appearance that something was searched for and no results were found. That is misleading!

- Another alternative would be (if we want to keep A/Q bindings) that a user-error or error be thrown if the correct external dependencies are not installed. The user should be let known that they need to install the GNU find/grep executables for their platform in order to use those commands. In the current implementation, the user will just assume that they searched something and nothing got returned.

- The requirement to have find/grep installed should also go to backward incompatible changes section in NEWS.


Kaushal Modi

reply via email to

[Prev in Thread] Current Thread [Next in Thread]