[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23288: 25.0.92; Clicking on links inserts primary X selection

From: Philipp Stephani
Subject: bug#23288: 25.0.92; Clicking on links inserts primary X selection
Date: Wed, 11 May 2016 13:01:55 +0000

There was a small bug in the patch. I've attached a new version that hopefully fixes that.

Nils Berg <address@hidden> schrieb am Mi., 11. Mai 2016 um 10:32 Uhr:
Still no dice, sorry.  I just tried the patched version with the original example:
echo -n bar | xsel -i && \
  emacs -Q -eval \
  "(insert (propertize \"foo\" 'follow-link (lambda (pos) \"a\")))"

Now when I click foo nothing happens in the buffer, but there's an error message:
Function mouse--down-1-maybe-follows-link returns invalid key sequence

I can't think of a reason why though :(

M-x version: GNU Emacs (x86_64-pc-linux-gnu, GTK+ Version 3.10.8)

On Wed, May 11, 2016 at 10:14 AM, Eli Zaretskii <address@hidden> wrote:
> From: Philipp Stephani <address@hidden>
> Date: Tue, 10 May 2016 21:25:47 +0000
> Cc: address@hidden
>  Agreed. https://debbugs.gnu.org/cgi/bugreport.cgi?bug=17887 might also be related.
> I've attached a new patch that should hopefully correct the behavior.

Thanks.  If no one objects in a week, please push to the master

Attachment: 0001-Fix-handling-of-mouse-on-link-p.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]