bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23759: 25.1.50; open-tls-stream creates malformed gnutls-cli command


From: Eli Zaretskii
Subject: bug#23759: 25.1.50; open-tls-stream creates malformed gnutls-cli command if trusted cert files don't exist
Date: Mon, 13 Jun 2016 17:03:02 +0300

> From: Lars Ingebrigtsen <address@hidden>
> Cc: address@hidden (Francis Litterio),  address@hidden
> Date: Mon, 13 Jun 2016 12:18:15 +0200
> 
> Eli Zaretskii <address@hidden> writes:
> 
> > TLS connections on MS-Windows are supported via the GnuTLS library.
> > External TLS programs will never work correctly on Windows, since they
> > use signals to communicate with Emacs.  So there's little sense in
> > fixing this issue, because the result will not work anyway.
> 
> Perhaps it would make sense to just have `open-tls-stream' signal an
> error on Windows to avoid confusing people?  I think this is at least
> the fourth bug report where people have spent significant time trying to
> debug something that will never work.
> 
> It could just say (error "Use an Emacs built with TLS support (and with
> installed gnutls libraries)").

At least a warning sounds like a good idea.  Not so sure about
erroring out, though.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]