[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23755: 25.0.95; Emacs 25.0.95 Line number is in fringe

From: James Nguyen
Subject: bug#23755: 25.0.95; Emacs 25.0.95 Line number is in fringe
Date: Fri, 17 Jun 2016 10:48:51 -0700
User-agent: mu4e 0.9.16; emacs 24.5.1

The font is https://github.com/madmalik/mononoki which I believe is fixed-width.

Alan Third writes:

> On Fri, Jun 17, 2016 at 10:21:01AM +0300, Eli Zaretskii wrote:
>> Sorry, still not reproducible.  Maybe there's something else to be
>> done?  Here's the complete recipe I used, after downloading
>> smart-mode-line and rich-minority which it requires:
>>   emacs -Q
>>   (add-to-list 'load-path "/path/to/smart-mode-line-master")
>>   (load-library "smart-mode-line")
>>   (sml/setup)
>>   (dolist (sym '(mode-line mode-line-inactive))
>>         (set-face-attribute
>>          sym nil
>>          :box `(:line-width 2 :color ,(face-attribute `,sym :background))))
>> I see no display problems in the mode line after the above.
> I just tried this on the NS port and it leaves stuff behind. The line
> number goes over into that left-hand section, which is fine since it's
> not the fringe.
> Aside from that, the digits seem to be placed wrongly. Sometimes
> they're fine, other times they're all wonky. I've attached a
> screenshot where it's displaying 404, but it looks like the 0 is too
> far left, and the second 4 is cut off, and another screenshot after I
> paged down and you can still see the left edge of the zero.
> I don't see any other characters that are obviously displayed wrong.
> I don't know how to tell what font it is, but I suspect it's
> variable-width and Emacs doesn't notice when they change size. For
> example, the misplaced 0 in 404 occurs after scrolling from a number
> starting with 3, and the 3 appears to be narrower than the 4. The
> second digit doesn't move right to compensate for the larger first
> digit. When it finally does move, it leaves artifacts behind.
> Changing line-width to 1 in your code fixes it.

James Nguyen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]