bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23819: 25.0.95; display botched badly in xterm window


From: Eli Zaretskii
Subject: bug#23819: 25.0.95; display botched badly in xterm window
Date: Wed, 22 Jun 2016 22:00:23 +0300

> Cc: address@hidden
> From: Paul Eggert <address@hidden>
> Date: Wed, 22 Jun 2016 20:55:57 +0200
> 
> > The "ESC [ > 1;3201;0c" thingy is the response to query by 
> > xterm--query, see xterm--version-handler. Is it true that all these 
> > problems happen right in the beginning of a session? What happens if 
> > you wait at least 2 sec after starting a session, without typing any 
> > commands -- do these problems still happen?
> 
> I have observed the problem in later parts of a session. In particular, 
> after a problem occurs and I type control-L to refresh the screen 
> completely, I have observed the problem recur in the same Emacs session. 
> Typically the problem occurs during interactive search, when substrings 
> are being highlighted in the text and in the minibuffer. Typically I am 
> searching code, where keywords and suchlike are also highlighted. I 
> assume all this highlighting is being done in the background.

When you say "the problem" here, do you mean the "ESC [ > ..."
response?  IOW, do you see this sequence in Emacs input stream in the
middle of a session?  That would be highly unusual, as AFAIK we only
query the terminal at the session beginning.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]