bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#24229: 25.1; Can't set EPA program


From: Daiki Ueno
Subject: bug#24229: 25.1; Can't set EPA program
Date: Wed, 17 Aug 2016 09:46:01 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1.50 (gnu/linux)

Nick Helm <address@hidden> writes:

> None of these variables forces the use of customize. Why 
> is epg-gpg-program such a special case?

That is primarily because of the UX differences between three maintained
versions of GnuPG: 2.0, 2.1, and 1.x.  GnuPG 2.0 does not provide a way
to prompt passphrase without GUI, but others do.  Some people are fine
with 2.0 as they use Emacs on a graphical environment only, but other
people are not.

So, we really need to take account of user's intention here; check
whether the variable set by user or it is the default value.  With
'setq' it is not possible to have such distinction.

Regards,
-- 
Daiki Ueno





reply via email to

[Prev in Thread] Current Thread [Next in Thread]