bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#6685: 23.2; Discards control characters during boot.


From: Trent W. Buck
Subject: bug#6685: 23.2; Discards control characters during boot.
Date: Thu, 15 Sep 2016 00:46:38 +1000
User-agent: Mutt/1.5.23 (2014-03-12)

Eli Zaretskii wrote:
> > From: Andrew Hyatt <address@hidden>
> > Cc: address@hidden,  address@hidden
> > Date: Sat, 10 Sep 2016 23:53:03 -0400
> >
> > Yes, you are correct - I must have had a typo.  When I tried it again
> > today, it works as you describe, and I was able to reproduce the
> > original bug.  Thanks for the help.
>
> The original bug is probably due to the initial queries we make to see
> if xterm supports some advanced features.  Can you see if this is
> indeed the culprit?

I tried adding

    (setq xterm-extra-capabilities nil)

to my ~/.emacs and as at

    GNU Emacs 24.4.1 (x86_64-pc-linux-gnu) of 2014-10-26 on trouble,
    modified by Debian

...I still saw that M-x turned into just x if I typed it while Emacs
was starting (using ALTERNATE_EDITOR= emacsclient -c -t).

I tried using *just* that line as my .emacs,
but emacs started too fast for me to type the M-x. :-)

I don't have a 25.x handy to test with - since 24.4 has
xterm-extra-capabilities I hope it's new enough to be a useful test.

It definitely doesn't happen with just "emacs" instead of
"ALTERNATE_EDITOR= emacsclient -c -t".





reply via email to

[Prev in Thread] Current Thread [Next in Thread]