bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#24358: 25.1.50; re-search-forward errors with "Variable binding dept


From: Sam Halliday
Subject: bug#24358: 25.1.50; re-search-forward errors with "Variable binding depth exceeds max-specpdl-size"
Date: Sun, 23 Oct 2016 16:58:07 +0100

ok, that worked to source the .gdbinit and xbacktrace works now...
(this is a fresh session).

I don't know how to print out the parameters to this function. I tried
"info" (see below) but it's still giving ...


EMACSLOADPATH= gdb ../src/emacs
GNU gdb (GDB) 7.12
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ../src/emacs...done.
(gdb) break Fsigna
Function "Fsigna" not defined.
Make breakpoint pending on future shared library load? (y or [n]) y
Breakpoint 1 (Fsigna) pending.
(gdb) break Fsignal
Breakpoint 2 at 0x634e00: file eval.c, line 1476.
(gdb) source ../src/.gdbinit
SIGINT is used by the debugger.
Are you sure you want to change it? (y or n) [answered Y; input not
from terminal]
DISPLAY = :0
TERM = rxvt-unicode-256color
Breakpoint 3 at 0x583686: file emacs.c, line 354.
Temporary breakpoint 4 at 0x5ae0bc: file sysdep.c, line 915.
(gdb) run -batch --no-site-file --no-site-lisp -batch -l ja-dic-cnv -f
batch-skkdic-convert -dir "./../lisp/leim/ja-dic"
"SKK-DIC/SKK-JISYO.L"
Starting program: /home/fommil/build/emacs-git/emacs/src/emacs -batch
--no-site-file --no-site-lisp -batch -l ja-dic-cnv -f
batch-skkdic-convert -dir "./../lisp/leim/ja-dic"
"SKK-DIC/SKK-JISYO.L"
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffe72e5700 (LWP 24197)]
Reading file "/home/fommil/build/emacs-git/emacs/leim/SKK-DIC/SKK-JISYO.L" ...
Processing OKURI-ARI entries ...
Processing POSTFIX entries ...
Processing PREFIX entries ...
Collecting OKURI-NASI entries ...
collected 26% ...
collected 30% ...
collected 40% ...
collected 50% ...
collected 60% ...
collected 70% ...
collected 80% ...
collected 90% ...
Processing OKURI-NASI entries ...
processed 10% ...
processed 20% ...
processed 30% ...
processed 40% ...

Thread 1 "emacs" hit Breakpoint 2, Fsignal (error_symbol=...,
data=...) at eval.c:1476
1476    = (NILP (error_symbol) ? Fcar (data) : error_symbol);
(gdb) xbacktrace
"substring" (0xffff6f00)
"string=" (0xffff70a0)
"if" (0xffff7230)
"while" (0xffff7400)
"catch" (0xffff7600)
"let" (0xffff7860)
"and" (0xffff79f0)
"let" (0xffff7c50)
"and" (0xffff7de0)
"or" (0xffff7f70)
"let" (0xffff81d0)
"skkdic-breakup-string" (0xffff8380)
"or" (0xffff8690)
"and" (0xffff8820)
"or" (0xffff89b0)
"if" (0xffff8b40)
"let" (0xffff8da0)
"while" (0xffff8f70)
"let" (0xffff91e0)
"and" (0xffff9370)
"or" (0xffff9500)
"let" (0xffff9760)
"skkdic-breakup-string" (0xffff9910)
"not" (0xffff9be0)
"and" (0xffff9d70)
"or" (0xffff9f00)
"if" (0xffffa090)
"while" (0xffffa260)
"let" (0xffffa4c0)
"skkdic-reduced-candidates" (0xffffa670)
"setq" (0xffffa9b0)
"if" (0xffffab40)
"let" (0xffffada0)
"while" (0xffffaf70)
"let" (0xffffb1e0)
"save-current-buffer" (0xffffb390)
"skkdic-convert-okuri-nasi" (0xffffb540)
"let" (0xffffb900)
"save-current-buffer" (0xffffbab0)
"let*" (0xffffbcc0)
"skkdic-convert" (0xffffbe70)
"let" (0xffffc230)
"if" (0xffffc3f0)
"batch-skkdic-convert" (0xffffc6e8)
"command-line-1" (0xffffcf80)
"command-line" (0xffffd878)
"normal-top-level" (0xffffe040)

(gdb) bt
#0  0x0000000000634e00 in Fsignal (error_symbol=..., data=...) at eval.c:1476
#1  0x00000000006351d9 in xsignal (error_symbol=..., data=...) at eval.c:1582
#2  0x00000000006352ae in xsignal3 (error_symbol=..., arg1=...,
arg2=..., arg3=...) at eval.c:1609
#3  0x0000000000614d16 in args_out_of_range_3 (a1=..., a2=..., a3=...)
at data.c:169
#4  0x000000000063f687 in validate_subarray (array=..., from=...,
to=..., size=4, ifrom=0x7fffffff6e18, ito=0x7fffffff6e10) at
fns.c:1210
#5  0x000000000063f70c in Fsubstring (string=..., from=..., to=...) at
fns.c:1235
#6  0x0000000000636da4 in eval_sub (form=...) at eval.c:2177
#7  0x0000000000636c98 in eval_sub (form=...) at eval.c:2159
#8  0x0000000000631bb4 in Fif (args=...) at eval.c:385
#9  0x00000000006369df in eval_sub (form=...) at eval.c:2124
#10 0x0000000000631e85 in Fprogn (body=...) at eval.c:431

(gdb) info f
Stack level 1, frame at 0x7fffffff6cf0:
 rip = 0x6351d9 in xsignal (eval.c:1582); saved rip = 0x6352ae
 called by frame at 0x7fffffff6d40, caller of frame at 0x7fffffff6cc0
 source language c.
 Arglist at 0x7fffffff6ce0, args: error_symbol=..., data=...
 Locals at 0x7fffffff6ce0, Previous frame's sp is 0x7fffffff6cf0
 Saved registers:
  rbp at 0x7fffffff6ce0, rip at 0x7fffffff6ce8


On 23 October 2016 at 16:48, Eli Zaretskii <address@hidden> wrote:
>> From: Sam Halliday <address@hidden>
>> Date: Sun, 23 Oct 2016 16:42:20 +0100
>> Cc: address@hidden, address@hidden
>>
>> breaking on Fsignal is hitting the problem... not sure what to do
>> here. I can type "bt" but that's where my gdb skillz end... do you
>> want me to do anything else or is this enough?
>
> "bt" is a good start, thanks.  After that, the results of "xbacktrace"
> will help more.
>
>> I'd imagine seeing the contents of error_symbol and data would be
>> pretty useful. I'm not sure the etc/DEBUG .gdbinit file is being
>> loaded properly when invoked from the leim directory.
>
> You can read .gdbinit manually:
>
>   (gdb) source ../src/.gdbinit
>
> And yes, making sure error_symbol and data are as we expect them would
> be a good start.
>
> Thanks.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]