bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#24963: 26.0.50; toggle-frame-maximized broken by double-buffering pa


From: Óscar Fuentes
Subject: bug#24963: 26.0.50; toggle-frame-maximized broken by double-buffering patch
Date: Fri, 18 Nov 2016 20:52:15 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.50 (gnu/linux)

Stephen Berman <address@hidden> writes:

> I guess this is a toolkit-specific bug, then, perhaps GTK+ only.
>
> (Unfortunately, I cannot build with lucid or even with no toolkit: both
> fail with this error:
>
> /usr/lib64/gcc/x86_64-suse-linux/4.8/../../../../x86_64-suse-linux/bin/ld: 
> image.o: undefined reference to symbol 'png_set_longjmp_fn@@PNG16_0'
> /usr/lib64/libpng16.so.16: error adding symbols: DSO missing from command line
> collect2: error: ld returned 1 exit status
> Makefile:611: recipe for target 'temacs' failed
> )
>
> Steve Berman

Try installing the build dependencies. I don't know the respective
package names on SUSE. IIRC, on Ubuntu/Debian they are:

autoconf automake libpoppler-dev texinfo libjpeg-dev libncurses5-dev
libgif-dev libtiff-dev libpng-dev librsvg2-dev libotf-dev libxml2-dev
xaw3dg-dev libgnutls28-dev

I guess there is a command for installing the build dependencies of a
given binary package too.

Make sure that you start from a clean source directory:

$ cd emacs_source
$ git clean -f -d -x
$ ./autogen.sh

Now create a new build directory

$ mkgir build && cd build

This is what I use for Lucid:

$ path/to/emacs/source/configure --without-toolkit-scroll-bars 
--with-x-toolkit=lucid

If the error about png persists, add --without-png to the configure
command.

HTH.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]