bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#24953: 25.1; Possible inefficiency in UTF-8


From: Eli Zaretskii
Subject: bug#24953: 25.1; Possible inefficiency in UTF-8
Date: Mon, 21 Nov 2016 05:32:34 +0200

> From: Eli Barzilay <address@hidden>
> Date: Sun, 20 Nov 2016 17:32:07 -0500
> Cc: address@hidden
> 
> On Wed, Nov 16, 2016 at 3:16 PM, Eli Zaretskii <address@hidden> wrote:
> >>
> >> >> (I originally thought that all it gets me is a default encoding for
> >> >> non-ascii files...)
> >> >
> >> > You could customize just that, then.
> >>
> >> Using `prefer-coding-system'?  Or something else?
> >
> > Using setq-default.
> 
> Sorry for being thick, but which variable?

buffer-file-coding-system

> >> Doesn't that make sense if I almost always edit source code for
> >> languages that use utf-8 to read sources?
> >
> > Languages that use utf-8 should already encode in utf-8 by default.
> > Which ones don't?
> 
> I can't reproduce any such problems so perhaps whatever made me add it
> is no longer a problem...  However, since I removed the UTF-8 language
> setting on Windows I had one case which wasn't working right: I ran some
> `git show ...` to look at a past change in a (utf-8 encoded) source
> file; I ran it with `shell-command` and the resulting text that popped
> up had some junk next to some non-ascii characters.  I'm pretty sure
> that I didn't have such an issue with the setting on.
> 
> If this is not expected, I can try to get reproducible instructions.

It isn't expected with Emacs 25.1, as it specifically sets up things
assuming Git reports its data in UTF-8.  Are you sure you didn't set
i18n.commitEncoding in your Git configuration, or have some non-ASCII
text encoded in something other than UTF-8 in that repository?





reply via email to

[Prev in Thread] Current Thread [Next in Thread]