bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23619: Some epg tests fail


From: Daiki Ueno
Subject: bug#23619: Some epg tests fail
Date: Tue, 21 Feb 2017 11:43:04 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.50 (gnu/linux)

address@hidden writes:

> Daiki Ueno <address@hidden> writes:
>
>> address@hidden writes:
>>
>>> Although this doesn't solve the problem for gpg 2.0.
>>
>> For a proper fix, you might want to check how GPGME and its test suites
>> do.
>
> I don't see anything to handle gpg 2.0, specifically.  They do disable
> pinentry for versions below 2.1.  Maybe their tests don't work with 2.0
> either?

It sounds unlikely to me that they don't work with 2.0, because 2.0
support has been there for a decade.

If I understand correctly their tests use their own pinentry program for
2.0 and 2.1:
https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git;a=blob;f=tests/gpg/pinentry
https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git;a=blob;f=tests/gpg/Makefile.am;h=8e26a92f0c54ce3c76e63e223ce034dea11d6e71;hb=HEAD#l115

If your goal is to make epg tests work with all gpg versions, this could
be an option worth considering.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]