[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#27816: 26.0.50; X protocol error: BadPixmap (invalid Pixmap paramete

From: Jean Louis
Subject: bug#27816: 26.0.50; X protocol error: BadPixmap (invalid Pixmap parameter) on protocol request 55
Date: Thu, 27 Jul 2017 10:38:27 +0300

On Tue, Jul 25, 2017 at 09:33:19PM +0300, Eli Zaretskii wrote:
> > Date: Tue, 25 Jul 2017 20:48:24 +0300
> > From: Jean Louis <address@hidden>
> > Cc: Jean Louis <address@hidden>, address@hidden
> > 
> > > The file etc/DEBUG describes how to start Emacs in the X synchronous
> > > mode under a debugger (look for "X protocol errors").  Please invoke
> > > Emacs as explained there, and then show the backtrace when the
> > > breakpoint you set on the function x_error_quitter breaks.  This will
> > > tell us which code causes these errors, and hopefully provide enough
> > > hints to identify the reason of this.
> > > 
> > > Thanks.
> > 
> > Thank you. As I must run Emacs as daemon, to run emacsclient, to
> > start debugging, when I run it as daemon with the
> > option (x-synchronize t) then I get this error:
> > 
> > error: X windows are not in use or not initialized
> > 
> > To ensure normal operation, you should investigate and remove the
> > cause of the error in your initialization file.  Start Emacs with
> > the ‘--debug-init’ option to view a complete error backtrace.
> > Starting Emacs daemon.
> > (New file)
> > 
> > Or should I evaluate it later simply?
> Yes, please evaluate it after you have created the first C frame.

I am starting Emacs through screen, without X windows. So I started as:

gdb screen

then I do:

breakpoint x_error_quitter

It asks me for future loaded libraries, I said y.

Then I "run" and get screen and bash.

Then I start emacs as 

emacs --user admin --chdir /home/data1/protected (that is my home dir)

And then I connect to emacs as emacsclient

and evaluate (x-synchronize t)

and then if I connect each 4th or 5th time, not clearly known why,
then I get that bug, and X frame of new emacsclient is not appearing.

But back in debugger I do not see much, emacs as server is still
running. When I quit emacs, and screen, only then I can see backtrace
and it shows me nothing special related to emacs, just three lines.

Maybe you can help me, as I am doing something wrong, but I can replicate the 

If I just start emacs in X Window, and not in screen, in console,
under bash, without X Window, I do not get that bug, I tried repeating
it but I did not get it.

If I start it in console through screen, I get the bug.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]