[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#28403: 25.2; find-tag works, but xref-find-definitions

From: Winston
Subject: bug#28403: 25.2; find-tag works, but xref-find-definitions
Date: Sun, 10 Sep 2017 10:52 EDT

Dmitry kindly replied:
> find-tag just falls back to full text search, which 
> xref-find-definitions doesn't, by default.
> Because false positives will be more noticeable and annoying in its UI, 
> compared to find-tag's.

and previously replied:
>>> Try adding `tag-symbol-match-p' to
>>> etags-xref-find-definitions-tag-order. This example should work
>>> then, but you'll get more false positives (like treating return
>>> types as function names).

to which I'd replied:
>>     Noted for future reference...
>>     Since doing that doesn't change what etags writes to TAGS, I'm not
>> sure how that elisp change would result in function return types being
>> matched as function names, but no matter.

> Have you even tried this?

As my reply indicated, I had not, mainly because of your warning that
that solution would cause false positives.

However, I just tried it now, and, at least initially, it seems to do
fine, so I'm now willing to switch over.

If you haven't already done so, it's probably worth documenting this
solution somewhere so that others converting from find-tag can find this
fix via search (Google or otherwise).

Thanks!  I'll now consider this bug solved.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]