[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#28550: 25.2; Hydra: First example hydra in the docs doesn't work

From: N. Jackson
Subject: bug#28550: 25.2; Hydra: First example hydra in the docs doesn't work
Date: Sat, 23 Sep 2017 13:21:29 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.3 (gnu/linux)

At 17:54 +0200 on Friday 2017-09-22, Oleh Krehel wrote:
> 1. Remove ~/.emacs.d/elpa/hydra
> 2. Start emacs-25.2 -Q
> 3. Install hydra
> 4. Paste the code you mentioned.

At 14:56 +0200 on Saturday 2017-09-23, Oleh Krehel wrote:
> Please try to reproduce with my steps (especially emacs -Q and
> remove/reinstall). There's likely no reason for this code to
> stop working other than byte-compilation or config bug: it's
> worked fine for 2 months without anyone else complaining.

Hello Oleh,

Thanks for responding.

I just tried your steps above, but the problem persists.

1. I checked my ~/.emacs.d/elpa/ directory and saw there the hydra
package in ~/.emacs.d/elpa//hydra-0.14.0.

2. I went into the Emacs package manager and deleted the hydra

3. I exited Emacs.

4. I checked my ~/.emacs.d/elpa/ directory and the hydra-0.14.0
directory was gone.

5. I ran Emacs -Q.

6. M-x list-packages RET

7. I went to the hydra package in the list and marked it for
installation. Then I issued the `x' command to install it.

8. I pasted the hydra body into the scratch buffer:

  (defhydra hydra-zoom (global-map "<f2>")
    ("g" text-scale-increase "in")
    ("l" text-scale-decrease "out"))

9. I did C-x C-e to evaluate it.

10. I hit F2 to run it.

I got the same results as reported in my OP.

And, again, (as mentioned in my previous post) running

  (defhydra hydra-zoom ()
    ("g" text-scale-increase "in")
    ("l" text-scale-decrease "out"))

  (global-set-key (kbd "<f2>") 'hydra-zoom/body)

here instead, works fine.

> If I can't reproduce it on my side, I can't do much.

No, that is perplexing.

Is the fact that the overlay (or text properties or whatever it
is) that is supposed to colour some of the letters red in the
hydra prompt actually gets applied at point in the *scratch*
buffer a clue?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]