bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#28512: 26.0.60; undecorated frames on macOS 10.13 do not resize prop


From: Alan Third
Subject: bug#28512: 26.0.60; undecorated frames on macOS 10.13 do not resize properly
Date: Sat, 23 Sep 2017 20:11:44 +0100
User-agent: Mutt/1.9.0 (2017-09-02)

On Sat, Sep 23, 2017 at 07:31:50AM -0700, Aaron Jensen wrote:
> On Tue, Sep 19, 2017 at 2:44 PM, Aaron Jensen <address@hidden> wrote:
> > If you can reproduce on 10.12, it may be a recent regression
> > because I hadn’t ever noticed it and I’ve been using it on 10.12
> > for a month or two now at least.

I’ve fixed it, and I doubt it’s a regression because I can’t see how
it could have ever worked.

When creating a frame, sometimes the toolbar takes a while to draw and
we have to wait for it before we can do things like resize windows (or
else we get an annoying series of window resizes).

(It’s just occurred to me, while typing this out, that the whole way
we’re handling this is just broken. It should probably be completely
redone.)

Undecorated frames, like fullscreen windows, don’t have toolbars, so
the code always sees it as zero size and therefore never stops waiting
for it to draw.

This means it will never resize.

Of course, the actual NSWindow *does* resize, it’s just Emacs that
doesn’t. This is clearly broken.

I’ve added a check for whether the window is undecorated, the same as
we check if it’s fullscreen.

> Also, there looks like there was an issue with creating a new
> undecorated frame, it was not resizable but should be:

Although this maybe isn’t actually a bug (and undecorated windows
being resizable is), I’ve made it consistent by doing what you
suggest.

> Also, I'm getting occasional build failures on my 10.12 machine on
> emacs-26. Any idea what would cause this:
> 
<snip>
> ./Contents/PkgInfo: Can't create 'Contents/PkgInfo'
> 
> ./Contents/Resources/Credits.html: Can't create
> 'Contents/Resources/Credits.html'
> 
> ./Contents/Resources/Emacs.icns: Can't create 'Contents/Resources/Emacs.icns'
> 
> ./Contents/Resources/English.lproj/InfoPlist.strings: Can't create
> 'Contents/Resources/English.lproj/InfoPlist.strings'

Is it a permissions issue on your Emacs.app directory?
-- 
Alan Third





reply via email to

[Prev in Thread] Current Thread [Next in Thread]