bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#28512: 26.0.60; undecorated frames on macOS 10.13 do not resize prop


From: Aaron Jensen
Subject: bug#28512: 26.0.60; undecorated frames on macOS 10.13 do not resize properly
Date: Sat, 23 Sep 2017 14:35:53 -0700

On September 23, 2017 at 12:11:48 PM, Alan Third
(address@hidden(mailto:address@hidden)) wrote:
> On Sat, Sep 23, 2017 at 07:31:50AM -0700, Aaron Jensen wrote:
> > On Tue, Sep 19, 2017 at 2:44 PM, Aaron Jensen wrote:
> > > If you can reproduce on 10.12, it may be a recent regression
> > > because I hadn’t ever noticed it and I’ve been using it on 10.12
> > > for a month or two now at least.
>
> I’ve fixed it, and I doubt it’s a regression because I can’t see how
> it could have ever worked.

I can confirm that this fixed the visual issue, but, unfortunately, it
did not fix the mouse event issue on macOS 10.13. Mouse clicks still
pass right through the frame. In order to get mouse events to work, I
have to:

1. Turn undecorated off
2. Resize
3. Turn undecorated on

Any resize after undecorated is turned on leaves the clickable area “constant”.

I don’t know if it’s any help, but https://github.com/gnachman/iTerm2
(GPL) implements a no-title-bar mode that seems to work perfectly.
It’s resizable, respects mouse events, starts w/o a title bar/borders,
etc.

> > Also, there looks like there was an issue with creating a new
> > undecorated frame, it was not resizable but should be:
>
> Although this maybe isn’t actually a bug (and undecorated windows
> being resizable is), I’ve made it consistent by doing what you
> suggest.

For my usage I’d prefer they were resizable. Thanks!

> > Also, I'm getting occasional build failures on my 10.12 machine on
> > emacs-26. Any idea what would cause this:
> >
>
> > ./Contents/PkgInfo: Can't create 'Contents/PkgInfo'
> >
> > ./Contents/Resources/Credits.html: Can't create
> > 'Contents/Resources/Credits.html'
> >
> > ./Contents/Resources/Emacs.icns: Can't create 
> > 'Contents/Resources/Emacs.icns'
> >
> > ./Contents/Resources/English.lproj/InfoPlist.strings: Can't create
> > 'Contents/Resources/English.lproj/InfoPlist.strings'
>
> Is it a permissions issue on your Emacs.app directory?

I’m not sure. I cleaned up a few build folders and rebooted and it
built again. I was building with homebrew on that machine, so I’m not
sure if it was doing something strange. I hadn’t ever seen that until
today.

Thanks,

Aaron





reply via email to

[Prev in Thread] Current Thread [Next in Thread]