bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#28571: 25.3; Compile error on macOS Sierra


From: Alan Third
Subject: bug#28571: 25.3; Compile error on macOS Sierra
Date: Thu, 28 Sep 2017 22:39:06 +0100
User-agent: Mutt/1.9.0 (2017-09-02)

On Fri, Sep 29, 2017 at 05:58:27AM +0900, address@hidden wrote:
> > Patch pushed to emacs-26.
> 
> ???  The OP did not reply whether he installed the Command Line Tools.
> I still think the failure is due to not installing them.

Sorry, I missed that. I’ve reverted the change.

> As for binary compatibility issue, futimens, futimesat, utimensat are not
> the only such functions.
> For example, mkostemp, fstatat, fdopendir, readlinkat, and faccessat are
> available on macOS 10.12, but not on all older OS X versions that Emacs 26
> supports.
> If you want to build a binary on a new version so that it also runs on
> older versions,
> then you need to use config.status generated on the oldest version anyway.

Thanks for this information. There was a discussion a little while ago
about how to implement a single binary that works across macOS
versions and nobody thought of this particular issue.
-- 
Alan Third





reply via email to

[Prev in Thread] Current Thread [Next in Thread]