bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#28601: 26.0.50; configure: error: Emacs does not support 'x86_64-pc-


From: Eli Zaretskii
Subject: bug#28601: 26.0.50; configure: error: Emacs does not support 'x86_64-pc-msys' systems.
Date: Fri, 29 Sep 2017 12:37:30 +0300

> From: Andy Moreton <address@hidden>
> Date: Thu, 28 Sep 2017 14:10:25 +0100
> 
> On Wed 27 Sep 2017, Glenn Morris wrote:
> 
> > Vincent Belaïche wrote:
> >
> >> There is no such thing as a mingw64_shell.bat script, but there is a
> >> msys2_shell.cmd script, which one can launch with the -mingw64 for
> >> MSYSTEM to be set accordingly to MSYSTEM=MINGW64.
> >
> > Sounds like MinGW has changed how things work and the instructions in
> > nt/INSTALL.W64 need updating.
> >
> >> checking the compiler's target... x86_64-pc-msys
> >> configure: error: Emacs does not support 'x86_64-pc-msys' systems.
> >
> > This is MinGW-specific code added in https://debbugs.gnu.org/19111
> 
> 
> Newer MSYS2 installations have mingw32.exe, mingw64.exe and msys2.exe for 
> launching a
> shell for each of the build environments, which are more convenient for
> creating desktop shortcuts. Either of the first two can be used to build
> emacs, if the appropriate toolchain is installed.

Can you or someone else suggest a change for INSTALL.W64, if some
change is needed there?

Thanks.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]