bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#29423: 27.0.50; ls-lisp does not handle -F switch properly


From: Michael Albinus
Subject: bug#29423: 27.0.50; ls-lisp does not handle -F switch properly
Date: Sat, 25 Nov 2017 09:59:52 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Eli Zaretskii <address@hidden> writes:

Hi Eli,

>> Because it wasn't called. ls-lisp-classify-file was called only, if I'm
>> not mistaken.
>
> Right, and so the correct fix is below, I think.  Do you agree?

Yes. I've applied your patch instead of mine, and the corresponding test
still passes.

> We can install this on the release branch, unless the original problem
> with Tramp exists only on master.  Let me know.

Yes, please. The problem does not happen in existing Tramp, but in the
not published yet tramp-archive.el I'm working on. It shall support as
many older Emacsen as the existing Tramp; if it would be fixed in Emacs
26 it would be great.

If needed, I will add some compat code for older Emacsen (24, 25), as it
is tradition in Tramp.

> Thanks.

Best regards, Michael.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]