bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#24954: [PATCH] Support Python 3


From: Noam Postavsky
Subject: bug#24954: [PATCH] Support Python 3
Date: Sun, 03 Dec 2017 10:50:37 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.90 (gnu/linux)

tags 24954 fixed
close 24954 26.1
quit

I pushed Syohei's patch to emacs-26 [1: de68f337e3].


Justin Timmons <address@hidden> writes:

> argparse's subparsers have
> had an issue from 3.3-3.5+ which doesn't cause a failure when a
> subparser is omitted from the program's arguments. See the
> stackoverflow post here:
> http://stackoverflow.com/questions/18282403/argparse-with-required-subcommands#answer-18283730.

>      mainp = argparse.ArgumentParser()
> -    subp = mainp.add_subparsers()
> +    subp = mainp.add_subparsers(dest='command')
> +    subp.required = True

I'm not going to apply this because it still produces a confusing error
message:

    modhelp.py: error: the following arguments are required: command

And if I read correctly from that link, the underlying bug should be
fixed in 3.7.

> This raises the question of whether or not these should be converted
> to be python2/3 compatible, stay python2, or move to python3
> altogether. I wouldn't be able to answer that, but maybe one of the
> maintainers could weigh in on it (I'm not sure who exactly, since
> there's not much in the maintainer list about python).

For me it actually raises the question of whether this "modhelper" thing
should be rewritten in elisp...

[1: de68f337e3]: 2017-12-03 10:04:18 -0500
  modhelp.py: Support Python 3 (Bug#24954)
  
https://git.savannah.gnu.org/cgit/emacs.git/commit/?id=de68f337e36be7a40e5997ad6682770c42535c25





reply via email to

[Prev in Thread] Current Thread [Next in Thread]