bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#29767: 26.0.90; Failing auto-fill in message-mode because of bad sta


From: Jose Antonio Ortega Ruiz
Subject: bug#29767: 26.0.90; Failing auto-fill in message-mode because of bad state (comment-skip-end)
Date: Wed, 20 Dec 2017 01:39:35 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.90 (gnu/linux)

On Wed, Dec 20 2017, Katsumi Yamaoka wrote:

> On Tue, 19 Dec 2017 18:16:23 +0200, Eli Zaretskii wrote:
>>> "Jose A. Ortega Ruiz" <address@hidden> writes:
>
>>>>   - sometimes, when composing a reply to an email in gnus (major mode is
>>>>     message-mode there, auto-fill-mode is enabled), when a line is
>>>>     auto-filled and broken in two, do-auto-fill incorrectly thinks that
>>>>     it is inside a comment and adds a `> ' prefix to it.
>
>>> This has bugged me for a long time.  I also don't have a recipe, the
>>> issue has a Heisenbug-like behavior.  But it happens quite often - it
>>>>     even happens right now, I didn't comment this line.
>
>> What does "C-h l" show immediately after this happens?
>
> I found a way to reproduce this bug.  It requires there are two
> or more quoted lines just above the unquoted line to be filled,
> and the last quoted line has two or more >'s.  Interesting.
>
>
> The quick brown fox jumps over the lazy dog.
>> The quick brown fox jumps over the lazy dog.

not for me. i am answering here with a long line, and the two quoted
lines above don't trigger the bug on my side.  here you see the lines
that was auto-filled without any extra >.

i've also seen the bug triggered many times below cited lines with a
single >.


jao
-- 
Superficially there are right views and wrong views. When we look
deeply we find that all views are wrong.
  -Thich Nhat Hanh





reply via email to

[Prev in Thread] Current Thread [Next in Thread]