[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#29872: 26.0.90; `man' output encoding, hyphen chars

From: Drew Adams
Subject: bug#29872: 26.0.90; `man' output encoding, hyphen chars
Date: Sat, 30 Dec 2017 09:03:51 -0800 (PST)

> > I don't even know whether it is the VAL (which is
> > `(raw-text-dos . raw-text-unix)') that is incorrect
> > or it is the PATTERN (which is "bash") that is
> > incorrect, or both.
> If you don't have problems with Bash, then its existing association in
> the alist, as set by those cygwin-* libraries, is fine for you.  (The
> latest Cygwin uses UTF-8 by default, so if your Bash is fairly recent,
> I'd suggest to change the above as well, to use utf-8 instead of
> raw-text.  If your Bash is old, then you probably don't need to
> bother.)

My bash is from my Cygwin installation, which is old.

I mentioned here the one (known) problem that I have, which
is noted in the Commentary of `setup-cygwin.el', as follows.
I'm guessing that it is unrelated to the problem reported
for this bug, but I don't know that.

;;  NOTE:
;;   When using precompiled GNU Emacs (all versions, at least 20-25)
;;   with a Cygwin installation with Cygwin1.dll version 1.7.11-1, you
;;   have trouble running bash in emacs. On `M-x shell` you get:
;;    bash: cannot set terminal process group (-1):
;;          Inappropriate ioctl for device
;;    bash: no job control in this shell
;;   This shell then is rather useless, because apart from the missing
;;   job control some commands called in that shell just hang.
;;   People on the Cygwin mailing list have apparently suggested that
;;   it is a GNU Emacs problem.  This issue is still not resolved yet.
;;   Workarounds some people have tried:
;;   * Use Cygwin Emacs (package emacs-w32 uses the windows GUI, there
;;     are also X11 and console packages)
;;   * Don't upgrade Cygwin above Cygwin1.dll, version 1.7.9.
;;   See also https://www.emacswiki.org/emacs/NTEmacsWithCygwin.

That Emacs Wiki page has more info about this particular
problem.  I'm (obviously) no expert on this.

> For 'man', try this:
>   (setq process-coding-system-alist
>         (cons '("man" . (utf-8-dos . utf-8-unix))
>                process-coding-system-alist))

Thanks; I tried that.  It did not change the result -
the same problem as reported for this bug report.

Again I did `emacs -Q', loaded cygwin-mount.el then
setup-cygwin.el, then evaluated the above code to add
a `man' entry to `process-coding-system-alist', then
did `M-x man RET find RET'.  I again see the "preceâ€"
with the problematic "hyphen".

process-coding-system-alist is a variable defined in
‘C source code’.
Its value is
(("man" utf-8-dos . utf-8-unix)
 ("bash" raw-text-dos . raw-text-unix)
 ("[pP][lL][iI][nN][kK]" . #1=(undecided-dos . undecided-dos))
 ("[cC][mM][dD][pP][rR][oO][xX][yY]" . #1#))

reply via email to

[Prev in Thread] Current Thread [Next in Thread]