bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#28732: flymake mouse-wheel portability fix


From: Charles A. Roelli
Subject: bug#28732: flymake mouse-wheel portability fix
Date: Wed, 28 Feb 2018 20:02:22 +0100

> Date: Tue, 27 Feb 2018 21:31:33 +0200
> From: Eli Zaretskii <address@hidden>
> 
> > Date: Tue, 27 Feb 2018 20:28:42 +0100
> > From: address@hidden (Charles A. Roelli)
> > Cc: address@hidden
> > 
> > Thanks.  Is the following change (ignoring whitespace differences)
> > good for emacs-26?
> > 
> > diff --git a/lisp/progmodes/flymake.el b/lisp/progmodes/flymake.el
> > index 58bad8f..d58c5943 100644
> > --- a/lisp/progmodes/flymake.el
> > +++ b/lisp/progmodes/flymake.el
> > @@ -1078,7 +1078,9 @@
> >                       face ,face
> >                       mouse-face mode-line-highlight
> >                       keymap
> > -                     ,(let ((map (make-sparse-keymap))
> > +                     ,(when (and (boundp 'mouse-wheel-down-event)
> > +                                 (boundp 'mouse-wheel-up-event))
> > +                        (let ((map (make-sparse-keymap))
> 
> Is there any reason you cannot simply require mwheel in flymake?  Or
> does loading mwheel in a --without-x build fail?

Good point.  Can someone with a "--without-x" build handy check that?
"mwheel.elc" is in src/lisp.mk, so it confuses me that it would not be
immediately available.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]