bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#31316: Emacs hangs in `font_open_entity'


From: Eli Zaretskii
Subject: bug#31316: Emacs hangs in `font_open_entity'
Date: Sat, 05 May 2018 11:55:39 +0300

> Date: Mon, 30 Apr 2018 22:20:13 +0200 (CEST)
> Cc: address@hidden
> From: Werner LEMBERG <address@hidden>
> 
> >> Sort of, thanks.  After waiting a few seconds, Emacs now displays
> >> three characters, but navigation is hard: it takes a few seconds to
> >> move from character to character (I guess Emacs tries to reload the
> >> missing glyph again and again).
> > 
> > Well, maybe I went overboard with the 100 figure, and we should use
> > a much smaller number, like 10 or 20?
> 
> Maybe, yes.  I don't know enough of Emacs code to have an opinion on
> that.

I eventually went with 15.  Pushed to the master branch.

> The font is called `emmentaler-brace.otf' (part of lilypond,
> containing system braces for musical scores).  However, I wonder how
> this font can ever be considered as a fallback, since its SFNT (3,1)
> Unicode cmap contains only PUA character codes in the range
> 0xe100-0xe33f (and `fc-list -v' correctly lists that).  In other
> words, this font definitely doesn't contain anything relevant to the
> CJK character codes originally reported.

I asked for a backtrace from that loop:

> Please show a C-level backtrace from a breakpoint in that loop.  And
> if the breakpoint breaks more than once when you do nothing after
> invoking Emacs as shown in your OP, please show the backtraces from
> all the times that breakpoint breaks.
> 
> Maybe looking at the backtrace will help us understand why Emacs
> attempts to open that font.

Can you please produce that?  I'd like to close this bug report, but
maybe the backtrace will show us that something else should be done
here.

Thanks.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]