bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#31408: 25.3; Python.el shoult switch to python 3


From: G.
Subject: bug#31408: 25.3; Python.el shoult switch to python 3
Date: Thu, 10 May 2018 20:41:23 +0200

Le jeudi 10 mai 2018 à 14:31 -0400, Ista Zahn a écrit :
> On Thu, May 10, 2018 at 12:22 PM, Sébastien Gendre <address@hidden>
> wrote:
> > 
> > Python.el use Python 2.X as python interpreter.
> 
> What do you mean by this? The default value of
> `python-shell-interpreter' is `python'.
> 
> 
> But Python 2 will not be
> > maintained past 2020: https://www.python.org/dev/peps/pep-0373/
> > 
> > Python.el shoult switch to python 3.
> 
> What change exactly are you suggesting?

After thinking, it's more the job of the system to make usage of the
correct version of Python when Emacs call `python`.

Sorry, I send this report too quickly. ^_^'





reply via email to

[Prev in Thread] Current Thread [Next in Thread]