bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#31415: 27.0.50; Strange behavior on Command-$ in MacOS


From: John Mastro
Subject: bug#31415: 27.0.50; Strange behavior on Command-$ in MacOS
Date: Sun, 13 May 2018 08:46:54 -0700

Alan Third <address@hidden> wrote:
>> By default, the "command" key in MacOS is bound to "super". If I type
>> s-$, Emacs seems to wait for input that it never receives. Anything I
>> type afterward appears to be ignored, except `ESC ESC ESC', which gets
>> Emacs out of this state. However, even hitting `C-g' repeatedly does
>> not.
>>
>> The issue seems to be related to the command key rather than to "super"
>> or to the command bound to the key. In my configuration, I map command
>> to meta, and the same problem happens when I use M-$ to `ispell-word'.
>>
>> Using `M-$' with command as meta worked until relatively recently. It
>> would be great if it could be brought back or made to fail more
>> explicitly.
>
> Hmm, what’s happening is that macOS is going into a screenshot mode.
> You can see the shortcuts in system preferences ‐> keyboard ‐>
> shortcuts. I don’t know why you’ve not seen this before as I think
> it’s been the default in macOS for quite a while now.
>
> I don’t know if we can over‐ride this, and I don’t know that we’d want
> to.

Wow, indeed, you're right.

I say "wow" because I was extremely sure I'd been using Command-$ (as
M-$) semi-regularly on MacOS for years. However, this morning I tried
this at several commits a ways back, and it's clear I was
mis-remembering or hallucinating or something :)

Thanks, and sorry for the noise

        John





reply via email to

[Prev in Thread] Current Thread [Next in Thread]