bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#31603: 27.0.50; pinentry loopback disappeared


From: adrian . lanz
Subject: bug#31603: 27.0.50; pinentry loopback disappeared
Date: Sun, 27 May 2018 18:41:20 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

On Sa 26 Mai 2018 (12:04:46 -0400) Noam Postavsky writes:

>> On Sam 26 Mai 2018 (12:14:13 +0100) Basil L. Contovounesios writes:
>>
>>> then I think the problem with the referenced commit [1: 302e500087] is
>>> that it uses define-obsolete-variable-alias (see docstring) in epa.el
>>> after epg-pinentry-mode has already been defined in epg-config.el.
>
> Oh, you're right
>
>     emacs -Q --eval "(setq epa-loopback-mode 'loopback)" -l epa
>
> Then <f1> v epa-loopback-mode RET shows that it has been reset to nil.
>
>
> address@hidden writes:
>
>> This was actually the first thing I tried (and I just tried it again to
>> be sure): pinentry-loopback still fails.
>
> Well, it's at least part of the problem.  Can you double check that
> epa-loopback-mode has the right value?  When I apply Basil's patch, add
> 'allow-loopback-pinentry' to ~/.gnupg/gpg-agent.conf and (setq
> epa-loopback-mode 'loopback), then M-x epa-sign-file does give me a

(The variable name is epa-pinentry-mode, not epa-loopback-mode.)

> prompt in the minibuffer, as expected.

I confirm setting (setq epg-pinentry-mode 'loopback) in .emacs init file
solves the problem (I get again the minibuffer prompt).

The <contovob <at> tcd.ie> proposed patch leads to minibuffer passphrase
prompts, even with only the old (now obsoleted) variable (setq
epa-pinentry-mode 'loopback) present in the .emacs init file. In other
words, with this patch, users do not have to change the configuration
right away.

Thanks!





reply via email to

[Prev in Thread] Current Thread [Next in Thread]