bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#31737: 26.1.50; Gnus does not use mailutils movemail


From: Robert Pluim
Subject: bug#31737: 26.1.50; Gnus does not use mailutils movemail
Date: Fri, 08 Jun 2018 18:01:14 +0200

Eli Zaretskii <address@hidden> writes:

>> From: Robert Pluim <address@hidden>
>> Date: Wed, 06 Jun 2018 21:55:20 +0200
>> Cc: address@hidden
>> 
>> > I use gnus and have had no trouble with movemail. In emacs-26.1 I
>> > compiled using ./configure --with-mailutils and in my ~/.emacs I point
>> > the mail-source-movemail-program to "/usr/bin/movemail". Everything
>> > works fine.
>> 
>> So it looks like the --emacs flag is not necessary, which means we
>> could just change the default of mail-source-movemail-progam. [1]
>
> Sorry, I don't think I follow: mail-source-movemail-progam is a
> variable in Gnus, and its default is nil.

Yes, and in that case Gnus looks for movemail in 'exec-directory'
only, where emacs no longer installs it if it found Mailutils
movemail at configure time.

> And I don't see how you concluded that the --emacs flag is
> unnecessary: the Mailutils manual says it causes movemail to "output
> information used by Emacs rmail interface", i.e. this is unrelated to
> Gnus.

It wasn't a firm conclusion, it was a tentative one based on one
report. There╩╝s no real documentation on the '--emacs' flag that I
could find.

>> Footnotes: 
>> [1]  Eli, 26.2? This is an emacs-26 regression
>
> What exactly was the regression, and which change do you propose for
> the branch?

Gnus can no longer use movemail, even though at configure time it was
found.

The simplest fix is below, but it will cause people who currently have
Mailutils movemail installed, but an emacs built to not use it, to
start using it, so it makes me uncomfortable. Perhaps gnus should
check in 'exec-directory' first if mail-source-movemail-program is
nil, and then fall back to 'executable-find'? Or perhaps we should
just forget about 'our' movemail and require people to install
Mailutils.

diff --git i/lisp/gnus/mail-source.el w/lisp/gnus/mail-source.el
index d2850f4cee..1e328c9b43 100644
--- i/lisp/gnus/mail-source.el
+++ w/lisp/gnus/mail-source.el
@@ -301,7 +301,7 @@ mail-source-idle-time-delay
   :group 'mail-source
   :type 'number)
 
-(defcustom mail-source-movemail-program nil
+(defcustom mail-source-movemail-program (executable-find "movemail")
   "If non-nil, name of program for fetching new mail."
   :version "22.1"
   :group 'mail-source





reply via email to

[Prev in Thread] Current Thread [Next in Thread]