bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#31760: 26.1; ruby-mode enables flymake-rubocop by default if the rub


From: João Távora
Subject: bug#31760: 26.1; ruby-mode enables flymake-rubocop by default if the rubocop executable exists
Date: Fri, 08 Jun 2018 19:42:21 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Petko Bordjukov <address@hidden> writes:

> Emacs 26.1 enables flymake-rubocop by default if the rubocop executable
> is present in the system. Since most if not all of the warnings that
> Rubocop generates are not raised by Ruby I consider them not adopted by
> the Ruby community by default. Based on that, I propose that either
> using Rubocop by default is turned off, or at least a more inteligent
> per-project Rubocop detection scheme is implemented.
>
Paging Dmitry :-)





reply via email to

[Prev in Thread] Current Thread [Next in Thread]