bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#32189: 27.0.50; GCC 7 warning due to -Wformat-truncation=2


From: Eli Zaretskii
Subject: bug#32189: 27.0.50; GCC 7 warning due to -Wformat-truncation=2
Date: Fri, 20 Jul 2018 17:51:51 +0300

> Cc: address@hidden, address@hidden
> From: Paul Eggert <address@hidden>
> Date: Fri, 20 Jul 2018 07:37:18 -0700
> 
>  > maybe we should disable it for GCC 7 alone?
> 
> I'd rather not bother. Better to move on. The general rule for warnings 
> should 
> be to cater to the latest GCC, and not worry much about older ones. (I used 
> to 
> try doing things the other way and it was way more trouble than it was 
> worth.) 
> We need to cater to old compilers for correctness, but we don't need to do it 
> for warnings.

Having warnings from recent versions of the compiler, which are likely
to be used by frequent contributors, runs the risk of making them
ignore warnings, which I think is not a good thing.

Anyway, we solved this one, so no need to argue more.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]