bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#32318: wdired-test-bug32173-02 fails


From: Stephen Berman
Subject: bug#32318: wdired-test-bug32173-02 fails
Date: Tue, 31 Jul 2018 00:57:59 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

On Mon, 30 Jul 2018 14:46:51 -0400 Ken Brown <address@hidden> wrote:

> On 7/30/2018 2:02 PM, Glenn Morris wrote:
>> Package: emacs
>> Severity: minor
>> Version: 26.1.50
>>
>> emacs-26 branch at 0252f73, RHEL 7.5, wdired-test-bug32173-02 fails, see
>> log below. Identical failure on hydra.nixos.org, see eg
>> https://hydra.nixos.org/build/78668940 .
>
> I'm seeing the same thing on Cygwin, but only if the test is run from
> wdired-tests.elc (which happens by default when you run 'make check'). But the
> test passes if it is run from wdired-tests.el:
>
> $ make -C test wdired-tests TEST_LOAD_EL=yes
> make: Entering directory '/home/kbrown/src/emacs/i686/test'
> make[1]: Entering directory '/home/kbrown/src/emacs/i686/test'
>   GEN      lisp/wdired-tests.log
> Running 3 tests (2018-07-30 14:41:43-0400, selector `(not (tag :unstable))')
> Press C-c C-c when finished or C-c ESC to abort changes
>    passed  1/3  wdired-test-bug32173-01 (0.426361 sec)
> Press C-c C-c when finished or C-c ESC to abort changes
>    passed  2/3  wdired-test-bug32173-02 (0.240313 sec)
> Press C-c C-c when finished or C-c ESC to abort changes
>    passed  3/3  wdired-test-unfinished-edit-01 (0.130247 sec)
>
> Ran 3 tests, 3 results as expected (2018-07-30 14:41:44-0400, 0.797493 sec)

I think I've fixed this now, simply by requiring wdired (in emacs-26
951c5a1).

I had run make check several times before pushing the test file and all
tests were as expected, though there were a few byte-compiler warnings.
But after reading your reports, I also tried a batch run on the compiled
file and got the same failure.  Then I stepped through the ert test run
in edebug and found that on the first run from emacs -Q,
wdired-use-interactive-rename was nil at the point of failure, though it
was let-bound to t; on rerunning the test the let-binding held.  I don't
know why that happened, but I guess the autoloads in wdired.el aren't
enough to make sure all variables and functions are defined when used,
though again, I hadn't seen unexpected failures with make check.
Anyway, requiring the library being tested should have been obvious, and
I hope the problem is solved now.

Steve Berman





reply via email to

[Prev in Thread] Current Thread [Next in Thread]