bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#32334: Window resize fails in remote X11


From: Robert Pluim
Subject: bug#32334: Window resize fails in remote X11
Date: Mon, 06 Aug 2018 12:12:51 +0200

Eli Zaretskii <address@hidden> writes:

>> From: Robert Pluim <address@hidden>
>> Cc: address@hidden,  address@hidden
>> Date: Thu, 02 Aug 2018 15:49:07 +0200
>> 
>> Initial debugging showed that the appropriated XDBE calls are being
>> made, so perhaps the initial setup of the frame is at fault. More
>> debugging this weekend, I hope.
>
> Thank you for working on this annoying problem.

So hereʼs what I have so far:

- Either no other program on the internet uses XDBE, or if they do
  their users never use X11 forwarding over ssh
- The emacs toolkit type doesnʼt matter, they all have visual problems
  of one kind or another
- XDBE calls are definitely being made, and they're not returning
  errors
- Itʼs not a timing issue: if I delay the XDBE setup until after the
  initial frame has been set up and shown, then visual problems still
  start occuring immediately after the XDBE initialization

I also tested with Cygwin's XServer, which supports the double
buffering extension. I used the same ssh session, and emacs came up
and looked and worked fine.

So at this point itʼs looking more like an issue with VcXsrv than with
emacs. Iʼll see if I can engage with them after I get back from vacation.

Robert





reply via email to

[Prev in Thread] Current Thread [Next in Thread]