bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#32544: [ELPA] core packages need generated files


From: Philippe Vaucher
Subject: bug#32544: [ELPA] core packages need generated files
Date: Tue, 28 Aug 2018 17:17:00 +0200



On Mon, Aug 27, 2018, 17:52 Stefan Monnier <address@hidden> wrote:

>> Any help with this sysadmin side of things would be very welcome.
> Unfortunately, I also haven't enough experience with containers in order
> to be able to help you. There is the Emacs Docker project
> <https://hub.docker.com/r/silex/emacs>. Maybe the author, Philippe
> Vaucher, could help (I've added him in Cc).

Note that we don't need to run Emacs: we need to run makeinfo (and
potentially many other tools).  I tried to make an LXC container that
simply re-uses the host's filesystem (so it ends up barely more costly
than a chroot while providing a complete Debian system) and managed to
get it running on my own machine, but not on elpa.gnu.org.

Hello! I'd love to help but I don't understand what the issue is. For information Emacs does not build in docker out of the box because it needs to disable ASLR (see https://github.com/moby/moby/issues/22801).

Tell me what you need or what precise problem you are encountering and maybe I can clarify what needs to be done.

Kind regards,
Philippe

reply via email to

[Prev in Thread] Current Thread [Next in Thread]