bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#32609: 26.1; mail-strip-quoted-names:205


From: Noam Postavsky
Subject: bug#32609: 26.1; mail-strip-quoted-names:205
Date: Sun, 02 Sep 2018 14:07:51 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

tags 32609 + unreproducible
quit

> From: Dr. Johannes Brügmann <address@hidden>

>>> I   tried  to   reply  to   an  email   by  pressing   r,  R,   and  M-x
>>> gnus-article-reply-with-original.   None  of  them  worked.   Minibuffer
>>> displayed  "Mark  Set" but  nothing  happened.  I enabled  Debugging  on
>>> C-g. The *Backtrace*-buffer showed
>>>      string-match("\\`[ \t\n]*" "")
>>>      mail-strip-quoted-names("")
>>>      mail-dont-reply-to("address@hidden")
>>
>> If I evaluate (mail-dont-reply-to "address@hidden") it doesn't hang.

> The  mail address  i  wanted  to reply  to  didn't  contain any  special
> characters.  Neither did  the call  to mail-dont-reply-to.  I understand
> that special characters could cause such a behaviour.
>
> As part of following your question, I've put the original file back into
> its place, and  then i recompiled using  byte-compile-file and restarted
> emacs.   Now the  symtom is  no  longer reproducible.  Neither with  the
> originating email, nor with any others that i tested.

I think that means that it's not actually getting stuck in
mail-dont-reply-to, there is some wider loop and you just happened to
stop there.  Next this happens, try to continue a bit and see if you can
find where it loops back again.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]