[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#32628: 26; Rename `window-setup-hook'

From: Juri Linkov
Subject: bug#32628: 26; Rename `window-setup-hook'
Date: Wed, 05 Sep 2018 00:41:18 +0300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (x86_64-pc-linux-gnu)

> The doc string even admits that this name is bad:
>   (The name of this hook is due to historical reasons, and does not
>    reflect its purpose very well.)
> Why not rename it now, and deprecate the old name, aliasing it to the
> new name?
> What should the new name be?  Maybe something like
> `after-set-frame-parameters-startup-hook'?

This is the clear winner of the contest for the longest hook name.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]