bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#32446: Configure-time requirement for gnutls is too old


From: Noam Postavsky
Subject: bug#32446: Configure-time requirement for gnutls is too old
Date: Sat, 15 Sep 2018 10:44:04 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

tags 32446 + patch
quit

Eli Zaretskii <address@hidden> writes:

>> I'd guess that the required version in 'configure' needs to be increased.
>
> The problem is not with the minimum required version, because we have
> additional version-dependent cpp conditions in gnutls.c.  The problem
> is that we assumed these functions were available since GnuTLS 3.0.0,
> which is false.
>
> Ted, what would you propose to do with this issue?  Disable the
> relevant functionality for versions of GnuTLS that don't have these
> APIs?

I think we can keep most of the functionality: the missing APIs only
make a difference for AEAD ciphers, which are already disabled for
versions before 3.5.

Attachment: v1-0001-Fix-build-with-gnutls-versions-3.0-to-3.2-Bug-324.patch
Description: patch


reply via email to

[Prev in Thread] Current Thread [Next in Thread]