bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#32927: 27.0.50; libxml not found when building on macOS Mojave


From: YAMAMOTO Mitsuharu
Subject: bug#32927: 27.0.50; libxml not found when building on macOS Mojave
Date: Thu, 04 Oct 2018 14:24:04 +0900
User-agent: Wanderlust/2.15.9 (Almost Unreal) SEMI-EPG/1.14.7 (Harue) FLIM/1.14.9 (Goj┼Ź) APEL/10.8 EasyPG/1.0.0 Emacs/25.3 (x86_64-pc-linux-gnu) MULE/6.0 (HANACHIRUSATO)

On Thu, 04 Oct 2018 08:10:35 +0900,
Glenn Morris wrote:
> 
> 
> Is this the perennial "xcode-select --install" issue again?
> 
> Bug#18779, 22552, 24068, 27526#74, 29931, ...
> https://lists.gnu.org/r/emacs-devel/2015-11/msg01926.html

I've received a similar report for the Mac port, and the situation was
a bit different.  Unlike the previous versions, the Command Line Tools
package for Xcode 10 no longer installs the header files into
/usr/include on macOS 10.14 (*).

*: 
https://developer.apple.com/documentation/xcode_release_notes/xcode_10_release_notes

The culprit for the above case was the bogus libxml-2.0.pc file that
refers to nonexistent /usr/include.  Philipp, could you try

  $ pkg-config --cflags --libs "libxml-2.0 > 2.6.17

to see if it refers to /usr/include ?  If so, locate the erroneous
config file by the following command:

  $ pkg-config --variable pcfiledir "libxml-2.0 > 2.6.17"

                                     YAMAMOTO Mitsuharu
                                address@hidden





reply via email to

[Prev in Thread] Current Thread [Next in Thread]