bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#33040: 26.1.50; Epg prompt on Microsoft Windows differ from the GNU/


From: Eli Zaretskii
Subject: bug#33040: 26.1.50; Epg prompt on Microsoft Windows differ from the GNU/Linux on when asking passphrase
Date: Sat, 20 Oct 2018 13:17:25 +0300

> From: Pierre Téchoueyres <address@hidden>
> Date: Sun, 14 Oct 2018 17:53:50 +0200
> 
> diff --git a/lisp/epg.el b/lisp/epg.el
> index 8f26cd34ee..000366d76a 100644
> --- a/lisp/epg.el
> +++ b/lisp/epg.el
> @@ -655,7 +655,9 @@ epg--start
>                                 :command (cons (epg-context-program context)
>                                                args)
>                                 :connection-type 'pipe
> -                               :coding '(binary . binary)
> +                               :coding (if (memq system-type '(ms-dos 
> windows-nt))
> +                                              (cons locale-coding-system 
> locale-coding-system)
> +                                            '(binary . binary))
>                                 :filter #'epg--process-filter
>                                 :stderr error-process
>                                 :noquery t)))

Thanks.

I think a better solution is to use raw-text-unix on both Unix and
DOS/Windows.  Can you try that and see if doing so produces good
results on both systems?





reply via email to

[Prev in Thread] Current Thread [Next in Thread]