[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#30929: 26.0.91; Text drag and drop does not work

From: Alan Third
Subject: bug#30929: 26.0.91; Text drag and drop does not work
Date: Thu, 10 Jan 2019 19:23:52 +0000
User-agent: Mutt/1.10.1 (2018-07-13)

On Mon, Jan 07, 2019 at 11:38:33PM +1300, Nick Helm wrote:
> I like the default modifier actions - they match how drag and drop works
> on my other apps. I was worried having the modifiers independent of the
> Emacs modifiers might be a bit confusing with non-default bindings, but
> in practice it doesn't cause me any trouble.


> I also tried as many different dnd operations as I could think of. They
> all worked as expected except one - when I try to open a malformed URL
> Emacs creates a spurious buffer and freezes momentarily (C-g to clear).
> Specifically, I selected the text "file://~/test.txt" in TextEdit.app
> and dropped it into Emacs with Alt/Opt held down. Properly formed URLs
> work as expected and open the file.

I’ve dug into this a bit and I think that’s actually a valid URL as
far as Emacs is concerned. I’m not sure what protocol it’s trying to
use, but it matches the form file://hostname/filename. I assume the
freeze you see is it doing a lookup and if left long enough it will
time out (although it’s an extraordinarily long timeout if true).

I’ll push this to master now.
Alan Third

reply via email to

[Prev in Thread] Current Thread [Next in Thread]