[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#33870: 27.0.50; xref-goto-xref not configurable

From: Juri Linkov
Subject: bug#33870: 27.0.50; xref-goto-xref not configurable
Date: Sat, 19 Jan 2019 22:47:16 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (x86_64-pc-linux-gnu)

>> Like we already have such functions as window-in-direction and
>> windmove-display-in-direction, the new function could have a similar name
>> display-buffer-in-direction.
> OK (unless we find something better).

Then two new functions will have consistent names:


>>> - with one nomenclature for a reference window
>> For clarity the alist entry name could include the word "window":
>> (window . selected)
>> (window . main)
>> (window . <window_object>)
>> But for disambiguation maybe also add some prefix like
>> direction-window
>> from-window
> 'from-window' is not bad.  Maybe also 'reference-window'.  We don't
> use such a term in windmove.el.  There we just say that "WINDOW is the
> window that movement is relative to".


>> Ok, like (direction . up) and all aliases.
> 'direction' should be OK then.

Or 'dir' for short.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]