bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#34640: 26.1; ispell nil reference error when dictionary not found


From: Eli Zaretskii
Subject: bug#34640: 26.1; ispell nil reference error when dictionary not found
Date: Fri, 08 Mar 2019 11:19:48 +0200

> Date: Sun, 24 Feb 2019 10:27:09 -0800
> From: Mark Diekhans <address@hidden>
> BCC: Mark Diekhans <address@hidden>,
> 
> On the first call to ispell-word, if ispell-set-spellchecker-params fails to 
> find hunspell dictionaries on the first invocation it
> gives the useful error message:
>   "no default hunspell diectionary found"
> 
> On subsequence calls, it fails with
>    "Wrong type argument: stringp, nil"
> 
> call stack is
>   string-match("," nil 0)
>   split-string(nil "," t)
>   ispell-parse-hunspell-affix-file(nil)
>   ispell-hunspell-fill-dictionary-entry(nil) *
>   ispell-start-process()
>   ispell-init-process()
>   ispell-buffer-local-words()
>   ispell-accept-buffer-local-defs()
>   ispell-word(nil nil nil t)
>   funcall-interactively(ispell-word nil nil nil t)
>   call-interactively(ispell-word nil nil)
>   command-execute(ispell-word)
> 
> This is caused by ispell-set-spellchecker-params setting
> ispell-last-program-name before it has successfully completed.
> 
> a patch is attached that fixes this problem, resulting in a correct
> error message on subsequence uses of ispell-word

Thanks, I installed this on the master branch.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]