bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#35766: emacs saves utf-16 le xml files as utf-16 be


From: J S
Subject: bug#35766: emacs saves utf-16 le xml files as utf-16 be
Date: Thu, 16 May 2019 20:57:34 +0000

I should say that I'm using emacs for windows.  And it's preferring saving in big endian to little endian when this is the tag:

<?xml version="1.0" encoding="UTF-16"?>


From: J S <address@hidden>
Sent: Thursday, May 16, 2019 7:21 PM
To: Eli Zaretskii
Cc: address@hidden
Subject: Re: bug#35766: emacs saves utf-16 le xml files as utf-16 be
 
Try saving this xml file and opening it again:

<?xml version="1.0" encoding="UTF-16LE"?>


From: J S <address@hidden>
Sent: Thursday, May 16, 2019 7:15 PM
To: Eli Zaretskii
Subject: Re: bug#35766: emacs saves utf-16 le xml files as utf-16 be
 
Try saving this xml file and opening it again:

<?xml version="1.0" encoding="UTF-16LE"?>



From: Eli Zaretskii <address@hidden>
Sent: Thursday, May 16, 2019 6:22 PM
To: J S
Cc: address@hidden
Subject: Re: bug#35766: emacs saves utf-16 le xml files as utf-16 be
 
> From: J S <address@hidden>
> Date: Thu, 16 May 2019 17:11:21 +0000
>
> Xml files with this tag are saved as utf-16 be by emacs, even if the file was originally utf-16 le.  Using
> "UTF-16LE" instead will break the encoding and remove the BOM.
>
> <?xml version="1.0" encoding="UTF-16"?>

Did you try using utf-16le-with-signature?

Or maybe I don't understand the scenario: would you please describe a
full reproduction recipe, starting from "emacs -Q"?

Thanks.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]