bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#37141: 27.0.50; spelling doesn't work in XML comments


From: Vincent Lefevre
Subject: bug#37141: 27.0.50; spelling doesn't work in XML comments
Date: Thu, 22 Aug 2019 17:12:45 +0200
User-agent: Mutt/1.12.1+19 (078654a4) vl-117499 (2019-06-15)

On 2019-08-22 17:53:25 +0300, Eli Zaretskii wrote:
> > Date: Thu, 22 Aug 2019 16:29:42 +0200
> > From: Vincent Lefevre <address@hidden>
> > Cc: address@hidden
> > 
> > > We don't document every obscure feature in the manual, that would make
> > > it too large.  Some user options are left out.  I don't see why this
> > > one is important enough to add it, sorry.
> > 
> > That's not an obscure feature.
> 
> We will have to disagree on that, I think.

Well, now I know what it does excatly (my testing was incomplete),
I agree that's an obscure feature. But you misread my original
bug report, which was *only* about XML comments (obviously not
all markup): "spelling doesn't work in XML comments"

> > There's no reason to exclude XML comments by default.
> 
> Maybe we have a missing feature, then.

Yes, apparently a missing feature (unless there's some undocumented
variable with an obscure name and documentation...).

> > A user who does not know this variable and what it does will never
> > find it.
> 
> I didn't know about it, and yet found it in about 10 sec.

I searched only about "XML". The user is not expected to spend
hours trying to search every variant (HTML, SGML, SVG, MathML,
etc.).

-- 
Vincent Lefèvre <address@hidden> - Web: <https://www.vinc17.net/>
100% accessible validated (X)HTML - Blog: <https://www.vinc17.net/blog/>
Work: CR INRIA - computer arithmetic / AriC project (LIP, ENS-Lyon)





reply via email to

[Prev in Thread] Current Thread [Next in Thread]