bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#37165: lookup-family-specification test fails


From: Robert Pluim
Subject: bug#37165: lookup-family-specification test fails
Date: Sat, 24 Aug 2019 15:00:26 +0200

>>>>> On Fri, 23 Aug 2019 15:29:18 -0400, Glenn Morris <address@hidden> said:

    GM> Package: emacs
    GM> Severity: minor
    GM> Version: 27.0.50

    GM> The test lookup-family-specification fails on hydra.nixos.org:

    GM>     google.com/0 Name or service not known
    GM>     Test lookup-family-specification condition:
    GM>         (ert-test-failed
    GM>          ((should
    GM>            (network-lookup-address-info "google.com" 'ipv4))
    GM>           :form
    GM>           (network-lookup-address-info "google.com" ipv4)
    GM>           :value nil))
    GM>        FAILED   1/18  lookup-family-specification (0.002023 sec)

    GM> Perhaps the system doesn't having working DNS, in which case you
    GM> probably just want to add

    GM> (skip-unless (not (getenv "EMACS_HYDRA_CI")))

OK, Iʼve added that where appropriate.

    GM> I suppose this could be true of other systems too, but don't know how
    GM> you check that.

By doing a DNS lookup :-)

    GM> Note that test lookup-google passes, but based on the above it should 
not.
    GM> (should (length X)) seems like a buggy test condition (it passes when X
    GM> is nil).

Yes, plus some others pass that shouldn't. Should be fixed now.

Robert





reply via email to

[Prev in Thread] Current Thread [Next in Thread]