bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#39482: 26.3; set-fontset-font with emacs charset does not work corre


From: Eli Zaretskii
Subject: bug#39482: 26.3; set-fontset-font with emacs charset does not work correctly
Date: Fri, 07 Feb 2020 18:04:16 +0200

> From: address@hidden
> Date: Sat, 08 Feb 2020 00:11:23 +0900
> 
> (let* ((base "Courier New")
>        (size 18)
>        (un-spec "SimHei")
>        (tc-spec '("MingLiU"   . "big5"))
>        (sc-spec '("SimSun"    . "gb2312.1980"))
>        (jp-spec '("MS Mincho" . "jisx0208"))
>        (kr-spec '("BatangChe" . "ksc5601.1987"))
>        )
>   (set-charset-priority 'ascii)
>   (set-frame-font (format "%s-%g" base size t))
>   (set-frame-size nil 80 28)
>   (set-fontset-font t '(#x80 . #x10FFFF) un-spec)
>   (set-fontset-font t 'chinese-gb2312    sc-spec nil 'append)
>   (set-fontset-font t 'big5              tc-spec nil 'append)
>   (set-fontset-font t 'japanese-jisx0208 jp-spec nil 'append)
>   (set-fontset-font t 'korean-ksc5601    kr-spec nil 'append)

Why are you using 'append here?  AFAIU, that means the default fontset
settings, which are set up in fontset.el, are used first, and your
settings are only used as fallback, when the defaults fail to find a
glyph for a charcater.  That could explain why you see what you see.

Also, since we've already established that Uniscribe on Windows 10
sometimes fails in strange ways, please switch to Emacs 27 with
HarfBuzz, because otherwise investigating these problems could be a
huge waste of our time for no good reason.  You can find a relatively
recent build of the Emacs 27 snapshot here:

  https://alpha.gnu.org/gnu/emacs/pretest/windows/emacs-27/

Thanks.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]