bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#38727: 27.0.50; The frame refreshes when pressing 'C-h k'


From: HaiJun Zhang
Subject: bug#38727: 27.0.50; The frame refreshes when pressing 'C-h k'
Date: Fri, 21 Feb 2020 10:34:51 +0800

jun@jundeMac ~/s/emacs-git> xcode-select —install
xcode-select: error: command line tools are already installed, use “Software Update" to install updates

There are no updates for command line tools in “Software Update”. And I can’t upgrade xcode to latest version because it doesn’t support 10.13.6. It seems that I have to upgrade the OS.

I will keep with emacs 26 before I upgrade the os.

Thanks.
在 2020年2月21日 +0800 AM7:20,Alan Third <address@hidden>,写道:
On Thu, Feb 20, 2020 at 10:02:44AM +0800, HaiJun Zhang wrote:
Yes.
在 2020年2月20日 +0800 AM4:19,Alan Third <address@hidden>,写道:
On Wed, Feb 19, 2020 at 07:59:02PM +0800, HaiJun Zhang wrote:
I tried the master today. Emacs just shows a blank window.
I run it in src directory:
cd  src
./emacs -Q

OS: macOS 10.13.6.

You might be the first person to try it on macOS below 10.14, although
I don’t expect that to cause a problem.

Can you please send me the output generated when you compiled it, in
case I’m using something that’s been changed?

These errors are interesting:

ld: warning: text-based stub file /System/Library/Frameworks//AppKit.framework/AppKit.
tbd and library file /System/Library/Frameworks//AppKit.framework/AppKit are out of sy
nc. Falling back to library file for linking.
ld: warning: text-based stub file /System/Library/Frameworks//IOKit.framework/IOKit.tb
d and library file /System/Library/Frameworks//IOKit.framework/IOKit are out of sync.
Falling back to library file for linking.

I think that means the command line utils need to be reinstalled.

xcode-select --install

--
Alan Third

reply via email to

[Prev in Thread] Current Thread [Next in Thread]