bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#38992: 27.0.60; when enabled, fido-mode seems to break vc-git-grep


From: João Távora
Subject: bug#38992: 27.0.60; when enabled, fido-mode seems to break vc-git-grep
Date: Thu, 5 Mar 2020 11:51:35 +0000

On Thu, Mar 5, 2020 at 9:59 AM Dmitry Gutov <address@hidden> wrote:
But why? REQUIRE-MATCH is there for a reason. The caller does not expect
non-matching inputs, and is unlikely to handle them well.

If non-matching input can make sense, then the caller needs to be changed.

Sure, but before that happens, users get annoyed :-) so let's provide
an "out" for them.

No, I meant a problem in overall behavior. But it seems fine to me as well.

OK, at this point I think you should push this to Emacs 27, and I'll work with
it for a while and flag if I see some bad stuff.  We mostly need testing for this
new mode (I wonder how many people are testing it, besides the original
poster).

--
João Távora

reply via email to

[Prev in Thread] Current Thread [Next in Thread]