bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#39865: 28.0.50; Emacs crash


From: Robert Pluim
Subject: bug#39865: 28.0.50; Emacs crash
Date: Thu, 12 Mar 2020 10:33:00 +0100

>>>>> On Wed, 11 Mar 2020 18:58:41 +0200, Eli Zaretskii <address@hidden> said:

    Eli> This will pass any symbol, it doesn't really verify that the symbol
    Eli> identifies a font backend, does it?  Why not loop over
    Eli> font_driver_list instead?  Or do we need to support here font backends
    Eli> that were not yet registered?

Probably, but this doesnʼt fix everything anyway, see below.

    >> Setting font-backend to a supported value with default-frame-alist
    >> in .emacs should work, and does for me in master, at least switching
    >> from 'ftcrhb' to 'ftcr'. Switching from 'ftcrhb' to 'xft' crashes.
    >> 
    >> Hmm, switching to 'x' also crashes.

    Eli> And the above patch doesn't fix those crashes, does it?

It fixes the switch to xft, but not the switch to x.

Of course, what I should do is rebase
<https://debbugs.gnu.org/cgi/bugreport.cgi?bug=23386#43>

Yep, that fixes this for me. Of course it breaks the macOS build,
since that doesnʼt have a gui_default_font_parameter function
(yet :-) ).

Robert





reply via email to

[Prev in Thread] Current Thread [Next in Thread]