[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#49724: 27.2; Tramp /sudoedit:: does not preserve file security conte

From: Michael Albinus
Subject: bug#49724: 27.2; Tramp /sudoedit:: does not preserve file security context
Date: Sun, 25 Jul 2021 22:14:46 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)

xenodasein@tutanota.de writes:


>> I see. As said, caching is disabled when "emacs -Q" is called. This is a
>> problem for the sudoedit method. Could you try instead
>> emacs -Q --eval '(setq tramp-cache-read-persistent-data t)'
> That indeed worked. I also tried -q without the eval part and that works too, 
> thanks for your help.
> There isn't much hint to side effects like this on the 'Emacs
> Invocation' part of emacs manual, is this explained in elisp manual
> maybe? What I found is "-Q’ Equivalent to ‘-q --no-site-file
> --no-splash’." and that it doesn't load 'default.el'.

The described emacs invocation is Tramp specific. I've added the hint
meanwhile to the Tramp manual, chapter "6 Reporting Bugs and
Problems". It reads now

--8<---------------cut here---------------start------------->8---
   To exclude cache-related problems, flush all caches before running
the test, *note Cleanup remote connections::.  Alternatively, and
often better for analysis, reproduce the problem in a clean Emacs
session started with ‘emacs -Q’.  Then, TRAMP does not load the
persistency file (*note Connection caching::), and it does not use
passwords from ‘auth-source.el’ (*note Password handling::).  If you
really need a password cache, for example for the ‘sudoedit’ method,

     emacs -Q -l tramp \
       --eval '(setq tramp-cache-read-persistent-data t)' \
       --eval '(tramp-cleanup-all-connections)'
--8<---------------cut here---------------end--------------->8---

Did you have a chance to test the patch, solving your sudoedit selinux

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]