[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug-gnu-libiconv] gettext-0.17 - libtool expects nonexistent libattr.la

From: Poor Yorick
Subject: [bug-gnu-libiconv] gettext-0.17 - libtool expects nonexistent libattr.la
Date: Wed, 09 Apr 2008 21:39:07 +0000

This is gbout gettext, not iconv, but but I couldn't find a mailing list for
gettext, so decided to post it here.  Does anyone know of any gettext mailing

build of gettext-0.17 on Linux with gcc-4.2.2 and libtool-1.5.24 fails.  It
seems that libtool expects lib/libattr.la to exist, which it probably shouldn't
since my system only has libattr.so.  I tried using --disable-static, but I
still get the same error.  Any suggestions?  Here is the error:

        /bin/sh ../libtool --tag=CC   --mode=link gcc -m32 -std=gnu99  -g -O2
        -release 0.17
        -L/path/to/lib -liconv
        -R/path/to/lib -lacl -lc
        -lxml2 -L/path/to/lib
        -liconv -R/path/to/lib
        -L/path/to/lib -liconv
        -R/path/to/lib -lncurses
        -Wl,--enable-new-dtags -o libgettextlib.la -rpath
        areadlink.lo gl_array_list.lo backupfile.lo addext.lo basename.lo
        c-ctype.lo c-strcasecmp.lo c-strncasecmp.lo c-strcasestr.lo c-strstr.lo
        classpath.lo clean-temp.lo closeout.lo copy-file.lo csharpcomp.lo
        csharpexec.lo error-progname.lo execute.lo exitfail.lo fatal-signal.lo
        fd-ostream.lo file-ostream.lo concat-filename.lo findprog.lo fstrcmp.lo
        full-write.lo fwriteerror.lo gcd.lo  hash.lo html-ostream.lo
        html-styled-ostream.lo  javacomp.lo javaexec.lo javaversion.lo
        linebreak.lo gl_linkedhash_list.lo gl_list.lo localcharset.lo
        localename.lo lock.lo malloca.lo mbchar.lo mbslen.lo mbsstr.lo
        mbswidth.lo ostream.lo pipe.lo progname.lo propername.lo quote.lo
        quotearg.lo sh-quote.lo striconv.lo strnlen1.lo styled-ostream.lo
        term-ostream.lo term-styled-ostream.lo  tls.lo tmpdir.lo
        uniname/uniname.lo unistr/u16-mbtouc.lo unistr/u16-mbtouc-aux.lo
        unistr/u16-mbtouc-unsafe.lo unistr/u16-mbtouc-unsafe-aux.lo
        unistr/u8-mbtouc.lo unistr/u8-mbtouc-aux.lo unistr/u8-mbtouc-unsafe.lo
        unistr/u8-mbtouc-unsafe-aux.lo unistr/u8-uctomb.lo
        unistr/u8-uctomb-aux.lo uniwidth/width.lo wait-process.lo xmalloc.lo
        xstrdup.lo xerror.lo xmalloca.lo xreadlink.lo xsetenv.lo xstriconv.lo
        xvasprintf.lo xasprintf.lo acl.lo argmatch.lo asnprintf.lo
        file-has-acl.lo printf-args.lo printf-parse.lo safe-read.lo
        safe-write.lo tempname.lo vasnprintf.lo libcroco_rpl.la libglib_rpl.la  

        grep: /lib/libattr.la: No such file or directory
        /bin/sed: can't read /lib/libattr.la: No such file or directory
        libtool: link: `/lib/libattr.la' is not a valid libtool archive
        make[4]: Leaving directory 
        make[4]: *** [libgettextlib.la] Error 1
        make[3]: *** [all] Error 2
        make[2]: *** [all-recursive] Error 1
        make[3]: Leaving directory 
        make[2]: Leaving directory 
        make[1]: Leaving directory 
        make[1]: *** [all] Error 2
        make: *** [all-recursive] Error 1


reply via email to

[Prev in Thread] Current Thread [Next in Thread]